ProStockMaster v1.9.0 for Mac is built for Snow Leopard only. This is due to introduction of some third party code compiled for Snow Leopard, and backward-incompatible to Leopard and Tiger. Since Tiger almost disappeared from the market and Leopard can be upgraded to Snow Leopard for just $29 at Apple Store, we are willing to keep it this way. All the further ProStockMaster versions also will be build for Snow Leopard only.

Royalty Free Images